Priming AquaH2O Canister Filter

Discussion in 'Beginner Discussions' started by bradleygt, Nov 5, 2009.

  1. bradleygt

    bradleygt

    Joined:
    Oct 6, 2009
    Messages:
    17
    Likes Received:
    0
    Location:
    Cape Town
    Hi there

    I recently bought a second hand AquH2O aquarium that came with an external canister filter from the same company. It is an ACF-800. I am struggling to get th filter running properly and have no manual to guide me (google not much help either).

    Can anyone with the same type of filter please assist?
    What I've done based on advice on the internet for other makes:
    1. Got the siphoning going on the inlet pipe
    2. Turned on the filter for a few seconds - slight knocking noise and stopped
    3. Filled the canister with water
    4. Turned filter on again for few seconds - slight humming noise with no flow
    5. Got the siphoning going on the outlet pipe as well
    6. Turned on filter - still no flow and still slight humming

    I did remember to open the inlet and outlet valves before starting the filter!
    What else can I be missing?

    Thanks
     
  2. Guest




  3. AquaNewbie

    AquaNewbie AquaNewbie

    Joined:
    Jul 27, 2009
    Messages:
    88
    Likes Received:
    0
    Location:
    Cape Town
    remove the priming cap thingy, add some water in there and try again!
     
  4. Laure

    Laure Cyano Terminator

    Joined:
    Jan 20, 2009
    Messages:
    903
    Likes Received:
    10
    Location:
    Port Elizabeth
    Yes I have one of these they are not easy but once you get the hang of it then it will be fine. There is a cap in the top middle that you open and fill up with water to prime to cannister. Also shaking the inflow tube gently helps with the syphon until it is established.
     
  5. OP
    bradleygt

    bradleygt

    Joined:
    Oct 6, 2009
    Messages:
    17
    Likes Received:
    0
    Location:
    Cape Town
    Thanks, I'll try that. I really hope I have not bought a dud! :wondering:
     
  6. OP
    bradleygt

    bradleygt

    Joined:
    Oct 6, 2009
    Messages:
    17
    Likes Received:
    0
    Location:
    Cape Town
    It's working - yay!
    Thanks for the advice.
     
  7. ACE007

    ACE007 VA-TI-KA-KI

    Joined:
    Jul 29, 2009
    Messages:
    872
    Likes Received:
    12
    Location:
    /\/¯¯¯¯¯\/\ Goodwood
    bet you were itching the whole day to try this out !!!
     
  8. OP
    bradleygt

    bradleygt

    Joined:
    Oct 6, 2009
    Messages:
    17
    Likes Received:
    0
    Location:
    Cape Town
    @ACE007 - :p - you read me like a book! Glad the scratch was a positive one.
     

Recent Posts

Loading...
Similar Threads - Priming AquaH2O Canister Forum Date
Filter priming problems Filtration Aug 1, 2016
Self Priming HOB filter General Equipment discussion Oct 25, 2010
AquaH2o Tank New members Sep 26, 2012
AquaH2o new tank- should I be worried!? General Discussions Oct 20, 2010
My 1.2m AquaH2O Members Systems Jun 28, 2009
AquaH2O update General Discussions May 21, 2009
AquaH2O Aquariums General Discussions May 7, 2009

Share This Page