Plant issues

Discussion in 'Aquatic plants' started by Vince, Jul 9, 2018.

  1. Vince

    Vince Enthusiast

    Joined:
    Mar 1, 2013
    Messages:
    133
    Likes Received:
    31
    Location:
    Brackenfell, Cape Town
    Hey guys.
    Please can I get some advice. Some of my plants are a little worrying...
    While others seem to be doing fine.
    Please tell me what I'm doing wrong?
    Brown marks on the Anubia.
    The red ones colour seems a bit off...
    The crispus is growing really slow and the older leaves have Brown marks on them too...
    be95b79ba0ed94de2775ba61385ce07a.jpg998f921e9e7ea4f1cd9ad80927b35a52.jpg48d84e32fa09e06e3db60aacb2ba78fa.jpg046f1da6bd951faced48fd5b0ba857c1.jpg

    Sent from my EVA-L19 using Tapatalk
     
  2. Guest




  3. f-fish

    f-fish #unspecified

    Joined:
    Jun 27, 2009
    Messages:
    8,905
    Likes Received:
    1,613
    Location:
    JHB - Randburg
    good thing I am color blind .. sure it is not just some algae ?

    Later Ferdie
     
  4. OP
    Vince

    Vince Enthusiast

    Joined:
    Mar 1, 2013
    Messages:
    133
    Likes Received:
    31
    Location:
    Brackenfell, Cape Town
    I've tried brushing it off, I think it's a pigment in the actual leaf.

    Sent from my EVA-L19 using Tapatalk
     
  5. f-fish

    f-fish #unspecified

    Joined:
    Jun 27, 2009
    Messages:
    8,905
    Likes Received:
    1,613
    Location:
    JHB - Randburg
    Might also just be the transition form going emersed to immersed ...

    Later Ferdie
     
    Vince likes this.
  6. OP
    Vince

    Vince Enthusiast

    Joined:
    Mar 1, 2013
    Messages:
    133
    Likes Received:
    31
    Location:
    Brackenfell, Cape Town
    So I'm lacking patience as usual

    Sent from my EVA-L19 using Tapatalk
     
  7. f-fish

    f-fish #unspecified

    Joined:
    Jun 27, 2009
    Messages:
    8,905
    Likes Received:
    1,613
    Location:
    JHB - Randburg
    nah ... but maybe Rome and all that ...
     
    Vince likes this.
  8. krg007

    krg007

    Joined:
    Apr 3, 2015
    Messages:
    72
    Likes Received:
    9
    Location:
    Cape Town
  9. OP
    Vince

    Vince Enthusiast

    Joined:
    Mar 1, 2013
    Messages:
    133
    Likes Received:
    31
    Location:
    Brackenfell, Cape Town
    Not yet. Should be getting out by this weekend.

    Sent from my EVA-L19 using Tapatalk
     
  10. krg007

    krg007

    Joined:
    Apr 3, 2015
    Messages:
    72
    Likes Received:
    9
    Location:
    Cape Town
    Read that browning can also be caused by too little co2 in the tank.
     
    Vince likes this.
  11. OP
    Vince

    Vince Enthusiast

    Joined:
    Mar 1, 2013
    Messages:
    133
    Likes Received:
    31
    Location:
    Brackenfell, Cape Town
    Okay, hopefully the Co2 helps
    Sent from my EVA-L19 using Tapatalk
     
  12. Hendre

    Hendre Polypterus freak

    Joined:
    Oct 3, 2016
    Messages:
    2,778
    Likes Received:
    795
    Location:
    Cape town
    Some plants may not have optimal nutrient intake if they are newly planted, their fine root hairs may not be 100% yet. I think. Brown could be algae forming too, this is what otocinclus were invented for.
     
    Vince likes this.
  13. Jaco83

    Jaco83

    Joined:
    Sep 28, 2014
    Messages:
    342
    Likes Received:
    38
    Location:
    Roodepoort
    Your red plant will want added Iron in the water in order to keep it nice and red.
    How long has the tank been running? Hard to tell from the photos, but the brown does look a lot like algae (diatoms), which is very common in newly setup tanks, espacialy if there is excess silica in the water. But again, cant really tell from the photos, so might not be this.
     
    Vince likes this.
  14. OP
    Vince

    Vince Enthusiast

    Joined:
    Mar 1, 2013
    Messages:
    133
    Likes Received:
    31
    Location:
    Brackenfell, Cape Town
    Yea I def need iron!
    Thank has been running for around 3months now. I've used AlguMin but doesn't help.
    I'll just wait and see what happens...

    Sent from my EVA-L19 using Tapatalk
     

Recent Posts

Loading...
Similar Threads - Plant issues Forum Date
Plant ID ID Needed Today at 4:26 PM
Need help choosing plants for low tech tank Planted Tanks Feb 12, 2019
Plant ID ID Needed Feb 12, 2019
Wanted: Osmocote root tabs for planted tanks.... Wanted/Swop/Freebies Feb 12, 2019
Wanted: Carpet plants needed Wanted/Swop/Freebies Feb 8, 2019
RSS Feed 9 low light aquarium plants RSS Feeds Feb 5, 2019
Keeping livebearers with plants Beginner Discussions Feb 2, 2019

Share This Page